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TMD3702VC
Introduction

Introduction
The TMD3702VC evaluation kit comes with everything needed to evaluate the TMD3702VC. The
device features proximity detection, color sense (RGBC+IR), and digital ambient light sensing (ALS).

1.1

Kit Contents
Figure 1:
Evaluation Kit Contents

1.2

No.

Item

Description

1

TMD3702VC Daughter Card

PCB with TMD3702VC sensor installed

2

EVM Controller Board

Used to communicate USB to I2C

3

USB Cable (A to Mini-B)

Connects EVM controller to PC

4

Flash Drive

Include application installer and documents

Ordering Information
Ordering Code

Description

TMD3702VC-EVM

TMD3702VC Narrow ALS, Color and Proximity Sensor Evaluation Kit
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TMD3702VC
Getting Started

Getting Started
The software should be installed prior to connecting any hardware to the computer. Follow the
instructions found in the Quick Start Guide (QSG). This loads the required driver for the USB interface
and also the device’s graphical user interface (GUI).
The balance of this document identifies and describes the controls available on the GUI. In
combination with the TMD3702VC datasheet, the QSG and application notes available on the ams
website, www.ams.com, there should be enough information to allow evaluation of the TMD3702VC
device.
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TMD3702VC
Hardware Description

Hardware Description
The hardware consists of the EVM Controller, the TMD3702VC EVM daughter card, and a USB
interface cable. The EVM controller board provides power and I2C communication to the daughter
card through a seven pin connector. When the EVM controller is connected to the PC through USB, a
green LED on the board flashes once on power up to indicate the system is getting power.
For schematics, layout and BOM information, please see the documents included with the install
located in the TMD3702VC EVM folder (All Programs -> ams -> TMD3702VC EVM -> Documents).
Figure 2:
Evaluation Kit Hardware
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TMD3702VC
Software Description

Software Description
The main window (Figure 3) contains the system menus, system level controls, device information and
logging status. The ALS tab contains controls for the light sensing function and the Prox tab contains
settings for the proximity function. The application polls the ALS and proximity raw data continuously
and calculates the Lux, CCT, and prox standard deviation values.
Figure 3 :
Software Main Window

4.1

Connect Software to Hardware
On startup, the software automatically connects to the hardware. On successful initialization, the
software displays a main window, containing controls pertinent to the connected device. If the software
detects an error, an error window appears. If “Device not found or is unsupported” appears, verify the
correct daughterboard is properly connected to the EVM controller board. If “Cannot connect to EVM
board” appears, verify the USB cable is connected. When the EVM controller board is connected to
the USB, a green LED on the board flashes once on power up to indicate the USB cable is connected
and providing power to the system.
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If the EVM board is disconnected from the USB bus while the program is running it displays an error
message and then terminates. Reconnect the EVM board and restart the program.

4.2

System Menus
At the top of the window there are pull-down menus labeled “File”, “Log”, and “Help”. The File menu
provides basic application-level control. The Log menu is used to control the logging function, and the
Help menu provides version and copyright information for the application.

4.2.1

File Menu
The File menu contains the following functions:

Figure 4:
File Menu

The Reread Registers function forces the program to re-read all of the control registers from the
device and display them on the screen. This does not read the output data, because those registers
are continually read while the program is running.
The Lux Coefficients menu allows the user to Display, Load or Save the lux coefficients used to
calculate lux. See ALS Lux Coefficients section for more details.
Click on the Exit command to close the main window and terminate the application. Any unsaved log
data is cleared from memory. The application can also be close by clicking the red “X” in the upper
right hand corner.

4.2.2

Log Menu
The Log menu is used to control the logging function and to save the log data to a file. Log data is
accumulated in memory until it is discarded or written to a data file.
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Figure 5:
Log Menu

Click Start Logging to start the logging function. Each time the program polls the output information
from the device, it creates a new log entry showing the raw data values, the values of various control
registers, and the values entered by the user into the text fields near the bottom right corner of the
window.
Click Stop Logging to stop the logging function. Once logging is stopped, the data can be written to a
file, or the user can continue collecting additional data by clicking Start Logging again.
The Log a Single Entry command causes logging to start, collect one single entry, and immediately
stop again. This function is not available when logging is already running.
Click Clear Log to discard any data that has already been collected. If there is data in memory, which
has not been saved to disk, this function displays a prompt asking to verify it is OK to discard the data.
If the log is running when this function is clicked, the log continues running after the existing data is
discarded.
Click Save Log to save the collected log data to a csv file. This stops the logging function, if it is
active, and displays a file dialog box to specify where to store the logged data. The default file name is
described in the Log Status and Control Information section, but the file name may be changed if
desired.

4.2.3

Help Menu
The Help menu contains a single function: About.

Figure 6:
Help Menu
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The About function displays a dialog box (Figure 7) showing the version and copyright information for
the application and library. Click the OK button to close this window and continue.

Figure 7:
About Window

4.3

System Level Controls
Immediately below the top menu bar there are checkboxes used to control the system level functions
of the TMD3702VC device.
The Power On checkbox controls the PON function of the TMD3702VC. When this box is checked,
the power is on and the device can operate. When this box is unchecked, the power is off and the
device does not operate (The control registers can still be written, but the device does not function).
The ALS Enable checkbox controls the AEN function of the TMD3702VC. When this box is checked,
the device collects and report ALS data as programmed. When this box is unchecked, the ALS
functions do not operate.
The Prox Enable checkbox controls the PEN function of the TMD3702VC. Proximity detection is
enabled when this box is checked or disabled when unchecked.

4.4

Auto Polling
The application automatically polls the TMD3702VC raw data of ALS and Prox if enabled. The Poll
Interval displays the time between reads of the device.
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Device ID Information
The lower left corner of the window displays the ID number of the EVM Controller board, identifies the
device being used and displays the ID of the device.

4.6

Log Status and Control Information
The lower right corner of the window contains status information and controls for the logging function:

Figure 8:
Logging Status

This section contains text boxes that are stored in the log file data and used to build the file name for
the log file. If the data in these fields are changed, the new values are stored with any new data
logged. The default log file name is based on these values at the time the log file is written. If nothing
is entered in these boxes they default to a period (“.”).
Sample default file name:
TMD3702VC_1-2-3_Log_HH_MM_SS.csv
From Application
From User Input
The Count value displayed is a count of the number of samples currently in the log buffer.
The Elapsed Time value indicates the elapsed time since data logging was started.
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“ALS” Tab
The main portion of the screen contains a tab labeled ALS. The controls in this tab are divided into 3
sections, each performing a separate function.
Figure 9 :
ALS Tab

4.7.1

ALS Controls
The left side of the ALS tab contains controls to set various ALS settings.
The ATIME control sets the time of the ALS integration. ATIME can be adjusted in 2.778ms steps.
The AGAIN control is a pulldown menu which sets the analog gain of the ALS sensor. The values
available are 1x, 4x, 16x, 64x, 128x, 256x and 512x.
The WEN checkbox controls the ALS Wait feature. When this box is checked, the values for WTIME
and WLONG are used to determine the time between ALS cycles. When this box is unchecked, there
is no wait period between ALS cycles and the values of WTIME and WLONG are ignored.
The WTIME control sets the time to wait between ALS cycles. WTIME can be adjusted in 2.778ms
steps.
The WLONG checkbox controls sets the WTIME factor. When this box is checked, the wait time
between ALS cycles is extended by a factor of 12x.
The IR Mux checkbox sets the GDATA channel to be the IR channel. The Lux and CCT values are
invalid when IR Mux is checked.
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ALS Lux Coefficients
The TMD3702VC supplies information that is used to calculate Lux (unit of illumination). The Lux
equation for the TMD3702VC uses a combination of data from the sensor and various coefficients to
calculate the Lux value. The software is pre-configured with coefficients for an open-air configuration.
When the sensor is placed behind glass, different coefficients should be loaded into the software to
update the Lux equation. The coefficients can be loaded or saved to an XML file using the File menu.
To ensure the proper XML format first save the current coefficients using File > Lux Coefficients >
Save. Once the file is saved locate the XML file created and edit with a text editor such as notepad to
change the coefficients. Then go to File > Lux Coefficients > Load and select the XML file that was
updated.
The software can also automatically load new coefficients upon starting the GUI. To do this save the
XML file as TMD3702VC_luxeq.xml in the system documents directory
(%USERPROFILE%\Documents, also known as My Documents). Then restart the GUI and see a
dialog appear with the new coefficients displayed.
If you are experiencing trouble loading new coefficients, this may indicate a problem with the file
format. The XML file must contain all the required Lux equation elements to be loaded. The format of
the file follows the standard XML format and is as follows:
<?xml version="1.0" encoding="utf-8"?>
<!-- Device:TMD3702VC Saved:11/27/2018 9:41:28 AM -->
<luxeq>
<eq_values>
<coef name="DGF" value="833" />
<coef name="C_Coef" value="0.11" />
<coef name="R_Coef" value="-0.1" />
<coef name="G_Coef" value="0.29" />
<coef name="B_Coef" value="-0.27" />
<coef name="CT_Coef" value="7245" />
<coef name="CT_Offset" value="1605" />
</eq_values>
</luxeq>

4.7.3

ALS Output Data
The top right corner of the ALS tab displays the output data. This data is continuously read. The
polling interval is shown above the tab.
●
●
●
●
●
●

CDATA displays the Clear Channel data count.
RDATA displays the Red Channel data count.
GDATA displays the Green Channel data count or the IR Channel counts if IR Mux is checked.
BDATA displays the Blue Channel data count.
Lux displays the calculated lux.
CCT displays the calculated correlated color temperature.
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Note: If IR Mux is checked the Lux and CCT values are invalid.

4.7.4

ALS Data Plot
The remaining portion of the ALS tab is used to display a running plot of the collected ALS values and
calculated Lux. The last 350 values are collected and plotted on the graph. As additional values are
added, the old values will be deleted from the left side of the graph. To start the plotting function,
check the Enable Plot checkbox and select the Clear, Red, Green, Blue, or Lux checkbox.

Figure 10:
ALS Data Plot

The scale of the Y-axis of the plot can be adjusted by clicking on the small up and down arrows at the
top left corner of the plot. The scale can be set to any power of 2 from 64 through 65536.
Click the Clear Plot button to discard the current data and continue plotting the new data. Note if the
Clear Plot button is clicked while the plot is disabled, the data is discarded, but the actual plot will not
be updated until the plot function is re-enabled.

4.8

“Prox” Tab
The main portion of the screen contains a tab labeled Prox. The controls in this tab are divided into 3
sections, each performing a separate function.
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Figure 11 :
Prox Tab

4.8.1

Prox Controls
The left side of the Prox tab contains controls to set various Prox settings.
The PULSE controls the number of pulses used for each prox cycle. The number of pulses is the
PULSE value plus 1 and is displayed immediately to the right of the box.
The PPULSE_LEN control sets the width of all IR LED pulses within the proximity cycle. Longer
pulses result in increased proximity range and typically result in less electrical noise generated in the
analog front end.
The 16x checkbox sets the PPULSE_LEN factor. When this box is checked, the pulse length is
extended by a factor of 16x.
The PGAIN control is a pulldown menu that lets you select the analog gain of the proximity IR sensor.
The values that can be chosen are 1x, 2x, 4x and 8x.
The PLDRIVE control sets the drive strength of the IR LED current. The values range 2mA to 19mA.
The HW Prox Averaging control is a pulldown menu that defines the number of ADC samples
collected and averaged during a cycle. The values range from 0 (Disabled) to 7 (128 samples) where
each value is the exponent of 2 (2value).

Eval Kit Manual • PUBLIC
UG000414 • v1-00 • 2019-Jan-09

19 │ 14

Document Feedback

TMD3702VC
Software Description

The PRATE controls sets the duration of a single prox sample. The time is equal to (PRATE +1) *
87µs, with a range from PRATE = 0 (87µs) to PRATE = 255 (22.272ms). If HW Prox Averaging is set
then the total prox cycle time is multiplied by the number of samples to average.
The POFFSET controls shift PDATA to remove crosstalk from the proximity data. The values range
from -255 to 255.
The Cal button triggers the sensor’s proximity offset calibration sequence. This function automatically
selects a POFFSET to remove crosstalk from PDATA.
The Auto Pulse Control Disable checkbox disables the automatic pulse control (APC) function.
The Detect and Release controls are threshold software values used for the Det/Rel status indicator.
Detect is the PDATA value that indicates an object has been detected. Release is the PDATA value to
indicate the object is no longer present.

4.8.2

Prox Output Data
The top right corner of the Prox tab displays the output data. This data is continuously read. The
polling interval is shown above the tab.
●
●
●

4.8.3

PDATA displays the Proximity ADC channel data counts
StDev displays the calculated prox standard deviation based on the last 32 PDATA samples
Det/Rel shows the status of the detect and release thresholds. When PDATA goes above the
detect threshold the icon turns red and stays red until PDATA goes below the release threshold.

Prox Data Plot
The remaining portion of the Prox tab is used to display a running plot of the collected PDATA values.
The last 350 values are collected and plotted on the graph. As additional values are added, the old
values will be deleted from the left side of the graph. To start the plotting function, check the Enable
Plot checkbox.
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Figure 12:
Prox Data Plot

The scale of the Y-axis of the plot can be adjusted by clicking on the small up and down arrows at the
top left corner of the plot. The scale can be set to any power of 2 from 16 to 16384.
Click the Clear Plot button to discard the current data and continue plotting the new data. Note if the
Clear Plot button is clicked while the plot is disabled, the data is discarded, but the actual plot will not
be updated until the plot function is re-enabled.
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Resources
For additional information regarding the TMD3702VC, please refer to the datasheet. For information
regarding the installation of the TMD3702VC EVM host application software please refer to the
TMD3702VC EVM Quick Start Guide.
Designer’s Notebooks dealing with various aspects of optical measurement and optical measurement
applications are available. All content is available on the ams website www.ams.com.

For further information, please refer to the following documents:

●

TMD3702VC Datasheet

●

TMD3702VC EVM Quick Start Guide (QSG)

●

TMD3702VC EVM User’s Guide (this document)

●

TMD3702VC EVM Schematic Layout

●

TMD3702VC Optical Design Guide

●

TMD3702VC Proximity Design Guide
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Revision Information
Changes from previous version to current revision v1-00

Page

Initial version for release

●
●

Page and figure numbers for the previous version may differ from page and figure numbers in the current revision.
Correction of typographical errors is not explicitly mentioned.
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Legal Information
Copyrights & Disclaimer
Copyright ams AG, Tobelbader Strasse 30, 8141 Premstaetten, Austria-Europe. Trademarks Registered. All rights reserved.
The material herein may not be reproduced, adapted, merged, translated, stored, or used without the prior written consent of the
copyright owner.
Demo Kits, Evaluation Kits and Reference Designs are provided to recipient on an “as is” basis for demonstration and
evaluation purposes only and are not considered to be finished end-products intended and fit for general consumer use,
commercial applications and applications with special requirements such as but not limited to medical equipment or automotive
applications. Demo Kits, Evaluation Kits and Reference Designs have not been tested for compliance with electromagnetic
compatibility (EMC) standards and directives, unless otherwise specified. Demo Kits, Evaluation Kits and Reference Designs
shall be used by qualified personnel only.
ams AG reserves the right to change functionality and price of Demo Kits, Evaluation Kits and Reference Designs at any time
and without notice.
Any express or implied warranties, including, but not limited to the implied warranties of merchantability and fitness for a
particular purpose are disclaimed. Any claims and demands and any direct, indirect, incidental, special, exemplary or
consequential damages arising from the inadequacy of the provided Demo Kits, Evaluation Kits and Reference Designs or
incurred losses of any kind (e.g. loss of use, data or profits or business interruption however caused) as a consequence of their
use are excluded.
ams AG shall not be liable to recipient or any third party for any damages, including but not limited to personal injury, property
damage, loss of profits, loss of use, interruption of business or indirect, special, incidental or consequential damages, of any
kind, in connection with or arising out of the furnishing, performance or use of the technical data herein. No obligation or liability
to recipient or any third party shall arise or flow out of ams AG rendering of technical or other services.

RoHS Compliant & ams Green Statement
RoHS Compliant: The term RoHS compliant means that ams AG products fully comply with current RoHS directives. Our
semiconductor products do not contain any chemicals for all 6 substance categories, including the requirement that lead not
exceed 0.1% by weight in homogeneous materials. Where designed to be soldered at high temperatures, RoHS compliant
products are suitable for use in specified lead-free processes.
ams Green (RoHS compliant and no Sb/Br): ams Green defines that in addition to RoHS compliance, our products are free of
Bromine (Br) and Antimony (Sb) based flame retardants (Br or Sb do not exceed 0.1% by weight in homogeneous material).
Important Information: The information provided in this statement represents ams AG knowledge and belief as of the date that
it is provided. ams AG bases its knowledge and belief on information provided by third parties, and makes no representation or
warranty as to the accuracy of such information. Efforts are underway to better integrate information from third parties. ams AG
has taken and continues to take reasonable steps to provide representative and accurate information but may not have
conducted destructive testing or chemical analysis on incoming materials and chemicals. ams AG and ams AG suppliers
consider certain information to be proprietary, and thus CAS numbers and other limited information may not be available for
release.

Headquarters

Please visit our website at www.ams.com

ams AG

Buy our products or get free samples online at www.ams.com/Products

Tobelbader Strasse 30

Technical Support is available at www.ams.com/Technical-Support

8141 Premstaetten

Provide feedback about this document at www.ams.com/Document-Feedback

Austria, Europe

For sales offices, distributors and representatives go to www.ams.com/Contact

Tel: +43 (0) 3136 500 0

For further information and requests, e-mail us at ams_sales@ams.com
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